Re: Virtual Recorder utility not working correctly in Windows 10


Robin Frost
 

Hi,
Ah there ya see you never know what detail might spark a chase down a rabbit trail and what it might yield whether we want it to or not is another matter (laughs).
I’m happy to try and help whenever and however I can. If you’d like us to test any other variables just send out word.
Robin
 
 

From: Carlos
Sent: Monday, May 1, 2017 3:06 PM
To: main@TechTalk.groups.io
Subject: Re: [TechTalk] Virtual Recorder utility not working correctly in Windows 10
 
I'm still not sure why only some are experiencing problems, but based on the comment made by Robin, I tested with a couple of different audio devices and it actually worked.  It was initially not working with my Sound Blaster Audigy, but after testing I switched the default system playback device back to the Audigy and it is now working again.  My only guess at this point is that it must be some kind of intermittent issue with certain devices.  In either case, I did upload new packages because I discovered another issue in the process.  The portable version and the utility included in the installer are supposed to request elevated privileges to register the virtual capture device.  This was not working correctly in Windows 10 so it may have also possibly contributed to the problems some are experiencing.  At least with the portable version.  With the installed version registration of the component occurs during setup, but there is a utility included which allows you to reregister the DLL just in case.  The latest updates can be found on the page below as usual thanks to Rob Hudson.
----- Original Message -----
From: Carlos
To: main@TechTalk.groups.io
Sent: Monday, May 01, 2017 1:04 PM
Subject: Re: [TechTalk] Virtual Recorder utility not working correctly in Windows 10
 
Hi Robin,
 
At this point, I have no clue what is causing the problem for some users and not others, but I of course appreciate all feedback.  I'm not sure if the sound card being used would make a difference or not, but virtual capture does use the audio device configured as the system default so I suppose anything is possible.
----- Original Message -----
From: Robin Frost
To: main@TechTalk.groups.io
Sent: Monday, May 01, 2017 12:54 PM
Subject: Re: [TechTalk] Virtual Recorder utility not working correctly in Windows 10
 
Hi,
I mentioned the soundcard in the interest of being as factual and detailed as possible as obviously something was coming into play and you never know which bit of minutia might reveal something.  further virtual capture is the exact recording input source I was using. And as of this writing it is for whatever reason still working here under Windows 10 1703 (OS Build 15063.250)
For whatever it is or isn’t worth I hope Carlos finds it useful.
Robin
 
 
From: Gene
Sent: Monday, May 1, 2017 9:57 AM
To: main@TechTalk.groups.io
Subject: Re: [TechTalk] Virtual Recorder utility not working correctly in Windows 10
 
It's not the sound card that's the problem.  The player evidently no longer works when you use the option that doesn't record using a sound card.  I don't recall the name of the option but it's purpose is to allow recording of things such as Internet streams or other material you would have used a Stereo Mix sound card feature for in the past.  Now, you could use this feature if your sound card didn't support such an option or even if it did.
 
Gene
----- Original Message -----
From: Robin Frost
Sent: Monday, May 01, 2017 8:01 AM
To: main@TechTalk.groups.io
Subject: Re: [TechTalk] Virtual Recorder utility not working correctly in Windows 10
 
Hi,
It just worked for me 3 days ago under Windows 10 creator’s update. I’m using a SoundBlaster Omni USB soundcard.
Robin
 
 
From: Carlos
Sent: Monday, May 1, 2017 2:18 AM
To: main@TechTalk.groups.io
Subject: Re: [TechTalk] Virtual Recorder utility not working correctly in Windows 10
 
Interestingly, some users have reported that it still works for them so now I'm just confused.
----- Original Message -----
From: Carlos
To: Tech Talk
Sent: Monday, May 01, 2017 12:44 AM
Subject: Virtual Recorder utility not working correctly in Windows 10
 
Hello everyone,
 
It seems that the Virtual Recorder utility is no longer working in Windows 10.  Probably due to incompatibilities, the audio virtual capture device is causing FFmpeg to completely freeze up.  That's what I get for not testing more often.  I have no idea how long the problem has existed so it could go back to the Anniversary edition.  Unfortunately, there's not much I can do about this until or unless the developer updates the DLL.  Recording via the sound card/hardware audio devices still seems to work as expected, but the ability to record anything playing through the sound card is broken.  You can still use your sound card's
"Stereo Mix"/"What You Hear"
option if it has that capability to achieve similar results, but the primary reason for creating Virtual Recorder was for cards especially on laptops that do not have that feature.  My apologies.  I will of course post a fix if the DLL is ever updated, but considering that the last release was made three years ago, I won't be holding my breath.

Join main@TechTalk.groups.io to automatically receive all group messages.