Archive of Talkback


Robert Mendoza
 

Hi, I was trying to help my friends phone unit of android. However he told me that he accidentally update his Talkback to version 6.2
which causes his phone fails to runs strangely. And, I believe it is not compatible with his android version 5.1.1 system.

I tried to look and search the older version but no luck. If there is someone know the archive site to download the 6.1 I appreciate in advance.

Robert Mendoza

Join main@TechTalk.groups.io to automatically receive all group messages.