thunderbird question


Shelly Kane
 

Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7 and when I was done, I didn't close it fast enough and I got this thing about downloading the language dictionaries.  I can still do emails but that tries to download every time I get on the computer.  I have hit alt 4, control w, and escape and none of that works.  Is there a command for this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly


Gene
 

I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 
All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene

----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly




Gerald Levy
 


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald


 

On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly




Ron Canazzi
 

Hi Group,


I tried simulating this issue in Thunderbird.  I usually have spell as you go turned on so I don't run the spell check proper with F7.  I was able to reproduce this if somehow I tried choosing a different language pack under the spell checker main window.  When I did this, I got a loading message followed by the appearance of an add on manager window which prompted me to choose a different language pack. This dialogue using NVDA didn't work so well, bub by routing around, I did see in my case I only had the English language pack loaded.  I was able to tab to the close button, press enter and close this window.  When closing and reopening the message with spelling errors, the prompt to download other language packs did not occur. 


Simply try tabbing to the close button in this add on window if it opens again when you press F7, press enter or space bar on the button and see if that fixes the issue.


On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 
All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly



-- 
They Ask Me If I'm Happy; I say Yes.
They ask: "How Happy are You?"
I Say: "I'm as happy as a stow away chimpanzee on a banana boat!"


Gene
 

F7 does start the spell checker.  So does control shift p.  You can't assume that commands given in menus are the only ones.  F7 is such a common command to start the spell checker in all sorts of programs that I tried it when I was learning something about the program without even checking to see what the command is and it worked. 
 
Also, while I'm not sure what the person did, if you spellcheck a document and tab around the entire dialog, there is a combo box that says language.  Down arrow in that combo box and Thunderbird uses its built-in browser to go to the page on the Internet for downloading languages.  That is what was done, or perhaps another arrow key might do this as well.  But clearly an arrow key was pressed while in the language field of the spell checker.  I see no other thing that could have been done, being in the spell checker. 
 
I just tested this and that is what happened.  Now, when I close the program and open it, the internal browser takes me to the page.  This isn't an add-on.  this is the program itself.  How you stop it is something I don't know.  I may or may not get the answer one way or another.  But this is definitive evidence that just leaving the spell checker opened doesn't automatically do anything and it is a reminder to be careful not to press keys in a dialog when you are tabbing around just to see what is in it unless you specifically want to try something or explore something.  That's fine but clearly the person inadvertently pressed the down arrow key in the language combo box.   
 
I don't use Thunderbird.  I keep it on my computer to help with questions at times so I can experiment in this way with no inconvenience to myself.
 
Gene

----- Original Message -----
Sent: Wednesday, January 23, 2019 6:39 AM
Subject: Re: [TechTalk] thunderbird question


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald



On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly




Gene
 

Here is how you stop the behavior and an explanation.  Alt f4 closes a program.  Control f4 closes a window in a program or a tab in a program when you are tab browsing.  If you use f4 when you are in the internal browser because of this problem, you will close the program and opening it just repeats the behavior because the program assumes you want to continue downloading a language.  Control f4 closes the browser and you are in the add-ons manager.  Control f4 again closes the add-ons manager and places you back in the place you are usually when you open the program.  Now that you have closed these items individually, the program doesn't open them again when you run it. 
 
In summary, open the program.  Use control f4 to close the internal browser.  Use control f4 again to close the add-ons manager. 
 
And remember what control f4 does as opposed to alt f4.  it may be important to know at times.
 
Gene

----- Original Message -----
From: Gene
Sent: Wednesday, January 23, 2019 9:16 AM
Subject: Re: [TechTalk] thunderbird question

F7 does start the spell checker.  So does control shift p.  You can't assume that commands given in menus are the only ones.  F7 is such a common command to start the spell checker in all sorts of programs that I tried it when I was learning something about the program without even checking to see what the command is and it worked. 
 
Also, while I'm not sure what the person did, if you spellcheck a document and tab around the entire dialog, there is a combo box that says language.  Down arrow in that combo box and Thunderbird uses its built-in browser to go to the page on the Internet for downloading languages.  That is what was done, or perhaps another arrow key might do this as well.  But clearly an arrow key was pressed while in the language field of the spell checker.  I see no other thing that could have been done, being in the spell checker. 
 
I just tested this and that is what happened.  Now, when I close the program and open it, the internal browser takes me to the page.  This isn't an add-on.  this is the program itself.  How you stop it is something I don't know.  I may or may not get the answer one way or another.  But this is definitive evidence that just leaving the spell checker opened doesn't automatically do anything and it is a reminder to be careful not to press keys in a dialog when you are tabbing around just to see what is in it unless you specifically want to try something or explore something.  That's fine but clearly the person inadvertently pressed the down arrow key in the language combo box.   
 
I don't use Thunderbird.  I keep it on my computer to help with questions at times so I can experiment in this way with no inconvenience to myself.
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 6:39 AM
Subject: Re: [TechTalk] thunderbird question


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald



On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly




Gene
 

Perhaps that is what happens in newer versions of Thunderbird.  I never use the program and I haven't updated it for some time.  Whatever version is being used, either my solution or Ron's should work.
 
Gene

----- Original Message -----
Sent: Wednesday, January 23, 2019 9:04 AM
Subject: Re: [TechTalk] thunderbird question

Hi Group,


I tried simulating this issue in Thunderbird.  I usually have spell as you go turned on so I don't run the spell check proper with F7.  I was able to reproduce this if somehow I tried choosing a different language pack under the spell checker main window.  When I did this, I got a loading message followed by the appearance of an add on manager window which prompted me to choose a different language pack. This dialogue using NVDA didn't work so well, bub by routing around, I did see in my case I only had the English language pack loaded.  I was able to tab to the close button, press enter and close this window.  When closing and reopening the message with spelling errors, the prompt to download other language packs did not occur. 


Simply try tabbing to the close button in this add on window if it opens again when you press F7, press enter or space bar on the button and see if that fixes the issue.


On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 
All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly



-- 
They Ask Me If I'm Happy; I say Yes.
They ask: "How Happy are You?"
I Say: "I'm as happy as a stow away chimpanzee on a banana boat!"


Ron Canazzi
 

Hi Gerald,


F7 does also work to invoke the spell checker in later versions of Thunderbird.  I think this is what is called an undocumented feature.  People who used to use Outlook Express naturally choose this keystroke by mistake, so maybe Thunderbird developers added this for convenience.


On 1/23/2019 7:39 AM, Gerald Levy wrote:


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald


 

On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly



-- 
They Ask Me If I'm Happy; I say Yes.
They ask: "How Happy are You?"
I Say: "I'm as happy as a stow away chimpanzee on a banana boat!"


Gene
 

It may be undocumented but I wonder if there is a toolbar that uses it as a shortcut command.  At times, there are commands in tool bars that you won't find in menus and dialogs and that's one way you may not be aware of a command.  It is often not evident that such a tool bar exists when you are working with a program and not using some sort of screen review and even then, I'm not sure you necessarily hear such shortcut commands announced when you move through a tool baar.
 
Gene

----- Original Message -----
Sent: Wednesday, January 23, 2019 9:40 AM
Subject: Re: [TechTalk] thunderbird question

Hi Gerald,


F7 does also work to invoke the spell checker in later versions of Thunderbird.  I think this is what is called an undocumented feature.  People who used to use Outlook Express naturally choose this keystroke by mistake, so maybe Thunderbird developers added this for convenience.


On 1/23/2019 7:39 AM, Gerald Levy wrote:


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald



On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly



-- 
They Ask Me If I'm Happy; I say Yes.
They ask: "How Happy are You?"
I Say: "I'm as happy as a stow away chimpanzee on a banana boat!"


Gerald Levy
 


Yes, I just discovered myself that F7 invokes the TB spell checker, although this command is not listed on the complete list of TB shortcuts:


https://support.mozilla.org/en-US/kb/keyboard-shortcuts



Gerald



On 1/23/2019 10:40 AM, Ron Canazzi wrote:

Hi Gerald,


F7 does also work to invoke the spell checker in later versions of Thunderbird.  I think this is what is called an undocumented feature.  People who used to use Outlook Express naturally choose this keystroke by mistake, so maybe Thunderbird developers added this for convenience.


On 1/23/2019 7:39 AM, Gerald Levy wrote:


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald


 

On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly



-- 
They Ask Me If I'm Happy; I say Yes.
They ask: "How Happy are You?"
I Say: "I'm as happy as a stow away chimpanzee on a banana boat!"


Shelly Kane
 

Thank you everyone:


It's working just fine.  It's an add on manager.  Sorry that I didn't specify.  I will definitely try those commands if i get stuck in that again.  It has happened quite a few times.  Thanks again.

Shelly

On 1/23/2019 7:39 AM, Gerald Levy wrote:


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald


 

On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly




Shelly Kane
 

One more thing, when I use the thunderbird spell checker, how do i get out of it when I'm done?  Is there a close button?

Shelly

On 1/23/2019 7:39 AM, Gerald Levy wrote:


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald


 

On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly




Shelly Kane
 

Thank you.

On 1/23/2019 10:04 AM, Ron Canazzi wrote:

Hi Group,


I tried simulating this issue in Thunderbird.  I usually have spell as you go turned on so I don't run the spell check proper with F7.  I was able to reproduce this if somehow I tried choosing a different language pack under the spell checker main window.  When I did this, I got a loading message followed by the appearance of an add on manager window which prompted me to choose a different language pack. This dialogue using NVDA didn't work so well, bub by routing around, I did see in my case I only had the English language pack loaded.  I was able to tab to the close button, press enter and close this window.  When closing and reopening the message with spelling errors, the prompt to download other language packs did not occur. 


Simply try tabbing to the close button in this add on window if it opens again when you press F7, press enter or space bar on the button and see if that fixes the issue.


On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 
All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly



-- 
They Ask Me If I'm Happy; I say Yes.
They ask: "How Happy are You?"
I Say: "I'm as happy as a stow away chimpanzee on a banana boat!"


Shelly Kane
 

Gene:


Thank you for this explanation.  This is exactly what happens to me.  I must be hitting an arrow key when I enter on close and that's when this opens up and I can't get out.  I will know to be extra careful now.

On 1/23/2019 10:16 AM, Gene wrote:
F7 does start the spell checker.  So does control shift p.  You can't assume that commands given in menus are the only ones.  F7 is such a common command to start the spell checker in all sorts of programs that I tried it when I was learning something about the program without even checking to see what the command is and it worked. 
 
Also, while I'm not sure what the person did, if you spellcheck a document and tab around the entire dialog, there is a combo box that says language.  Down arrow in that combo box and Thunderbird uses its built-in browser to go to the page on the Internet for downloading languages.  That is what was done, or perhaps another arrow key might do this as well.  But clearly an arrow key was pressed while in the language field of the spell checker.  I see no other thing that could have been done, being in the spell checker. 
 
I just tested this and that is what happened.  Now, when I close the program and open it, the internal browser takes me to the page.  This isn't an add-on.  this is the program itself.  How you stop it is something I don't know.  I may or may not get the answer one way or another.  But this is definitive evidence that just leaving the spell checker opened doesn't automatically do anything and it is a reminder to be careful not to press keys in a dialog when you are tabbing around just to see what is in it unless you specifically want to try something or explore something.  That's fine but clearly the person inadvertently pressed the down arrow key in the language combo box.   
 
I don't use Thunderbird.  I keep it on my computer to help with questions at times so I can experiment in this way with no inconvenience to myself.
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 6:39 AM
Subject: Re: [TechTalk] thunderbird question


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald



On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly




Shelly Kane
 

Gene:


Thank you so much for getting an answer for me.  Now I will know what to do.  I thought the alt f4 would have worked but it did exactly what you said.  Every time I opened up the program, the same thing would happen again.  Now I will know to hit control instead of alt.  Take care and thanks.

Shelly

On 1/23/2019 10:33 AM, Gene wrote:
Here is how you stop the behavior and an explanation.  Alt f4 closes a program.  Control f4 closes a window in a program or a tab in a program when you are tab browsing.  If you use f4 when you are in the internal browser because of this problem, you will close the program and opening it just repeats the behavior because the program assumes you want to continue downloading a language.  Control f4 closes the browser and you are in the add-ons manager.  Control f4 again closes the add-ons manager and places you back in the place you are usually when you open the program.  Now that you have closed these items individually, the program doesn't open them again when you run it. 
 
In summary, open the program.  Use control f4 to close the internal browser.  Use control f4 again to close the add-ons manager. 
 
And remember what control f4 does as opposed to alt f4.  it may be important to know at times.
 
Gene
----- Original Message -----
From: Gene
Sent: Wednesday, January 23, 2019 9:16 AM
Subject: Re: [TechTalk] thunderbird question

F7 does start the spell checker.  So does control shift p.  You can't assume that commands given in menus are the only ones.  F7 is such a common command to start the spell checker in all sorts of programs that I tried it when I was learning something about the program without even checking to see what the command is and it worked. 
 
Also, while I'm not sure what the person did, if you spellcheck a document and tab around the entire dialog, there is a combo box that says language.  Down arrow in that combo box and Thunderbird uses its built-in browser to go to the page on the Internet for downloading languages.  That is what was done, or perhaps another arrow key might do this as well.  But clearly an arrow key was pressed while in the language field of the spell checker.  I see no other thing that could have been done, being in the spell checker. 
 
I just tested this and that is what happened.  Now, when I close the program and open it, the internal browser takes me to the page.  This isn't an add-on.  this is the program itself.  How you stop it is something I don't know.  I may or may not get the answer one way or another.  But this is definitive evidence that just leaving the spell checker opened doesn't automatically do anything and it is a reminder to be careful not to press keys in a dialog when you are tabbing around just to see what is in it unless you specifically want to try something or explore something.  That's fine but clearly the person inadvertently pressed the down arrow key in the language combo box.   
 
I don't use Thunderbird.  I keep it on my computer to help with questions at times so I can experiment in this way with no inconvenience to myself.
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 6:39 AM
Subject: Re: [TechTalk] thunderbird question


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald



On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly




Gene
 

The spellchecker closes itself.  You don't have to close it if it is working properly in that respect.  I don't know why you were using an arrow key.  On buttons, you never use arrow keys.
 
Gene
----- Orginal Message -----

Sent: Thursday, January 24, 2019 12:52 AM
Subject: Re: [TechTalk] thunderbird question

Gene:


Thank you for this explanation.  This is exactly what happens to me.  I must be hitting an arrow key when I enter on close and that's when this opens up and I can't get out.  I will know to be extra careful now.

On 1/23/2019 10:16 AM, Gene wrote:
F7 does start the spell checker.  So does control shift p.  You can't assume that commands given in menus are the only ones.  F7 is such a common command to start the spell checker in all sorts of programs that I tried it when I was learning something about the program without even checking to see what the command is and it worked. 
 
Also, while I'm not sure what the person did, if you spellcheck a document and tab around the entire dialog, there is a combo box that says language.  Down arrow in that combo box and Thunderbird uses its built-in browser to go to the page on the Internet for downloading languages.  That is what was done, or perhaps another arrow key might do this as well.  But clearly an arrow key was pressed while in the language field of the spell checker.  I see no other thing that could have been done, being in the spell checker. 
 
I just tested this and that is what happened.  Now, when I close the program and open it, the internal browser takes me to the page.  This isn't an add-on.  this is the program itself.  How you stop it is something I don't know.  I may or may not get the answer one way or another.  But this is definitive evidence that just leaving the spell checker opened doesn't automatically do anything and it is a reminder to be careful not to press keys in a dialog when you are tabbing around just to see what is in it unless you specifically want to try something or explore something.  That's fine but clearly the person inadvertently pressed the down arrow key in the language combo box.   
 
I don't use Thunderbird.  I keep it on my computer to help with questions at times so I can experiment in this way with no inconvenience to myself.
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 6:39 AM
Subject: Re: [TechTalk] thunderbird question


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald



On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly




Ron Canazzi
 

Yes there is a close button.


On 1/24/2019 1:47 AM, Shelly Kane wrote:

One more thing, when I use the thunderbird spell checker, how do i get out of it when I'm done?  Is there a close button?

Shelly

On 1/23/2019 7:39 AM, Gerald Levy wrote:


First of all, the correct command for invoking the Thunderbird spell checker is Shift-Control-P, not F7 as in MS-based email clients.  Pressing f7 in Thunderbird is the command for selecting text with the keyboar, so I don't know exactly what happened when Shelley pressed F7 and somehow invoked a download of a language dictionary. It sounds like she may have inadvertently invoked the Thunderbird Add-On Manager, which is prompting her to download a language dictionary add-on.  I don't know how to get rid of this prompt when Thunderbird is opened, other than perhaps letting this add-on install and then removing it from the Add-On Manager.  The only other commands I can suggest trying are Control-F4 or Control-Tab    . 


Gerald


 

On 1/23/2019 2:54 AM, Gene wrote:
I don't know why, but I looked up a help article on the language dictionaries and, as you will see if you read some of it, it is a completely different procedure than using f7. 

All f7 does is run the spell checker.  It doesn't download dictionaries based on this detailed and involved discussion of how to do it.  I've never seen a spell checker try to download anything just because it is running.  As far as stopping it is concerned, I don't know if you can or not but maybe the easiest thing to do is just to let the program download them and then just let them sit there, or delete them after they have been downloaded.  I didn't look at this carefully, but it appears that this download option will open your browser and take you to the downloads page.  Maybe just closing the browser wil solve the problem.  Maybe downloading the dictionaries will solve it. 
 
You may want to wait for more information from users but you don't have to worry about using f7 and not closing the spellchecker.  Something else caused you to see what you see. 
 
Gene
----- Original Message -----
Sent: Wednesday, January 23, 2019 1:22 AM
Subject: [TechTalk] thunderbird question

        Hi Group:


I was typing an email yesterday and used the spell checker.  I hit f7
and when I was done, I didn't close it fast enough and I got this thing
about downloading the language dictionaries.  I can still do emails but
that tries to download every time I get on the computer.  I have hit alt
4, control w, and escape and none of that works.  Is there a command for
this so this stops coming up when I open Thunderbird?  Thank you in advance.

Shelly



-- 
They Ask Me If I'm Happy; I say Yes.
They ask: "How Happy are You?"
I Say: "I'm as happy as a stow away chimpanzee on a banana boat!"